$re = '/^<p>(.*)</p>$/m';
$str = '<p><p>{\'Area\': \'Square\',</p>\\n<p> <tr> <td>\'Flag\': \'com\'}</p></p>';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;