re = /^<p>(.*)<\/p>$/m
str = '<p><p>{\'Area\': \'Square\',</p>\\n<p> <tr> <td>\'Flag\': \'com\'}</p></p>'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result