using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{2}:\d{2})";
string input = @"*Линия - 1*
Славянска 07:00 - Кремък 07:30 ;
Славянска 08:00 - Кремък 08:30 ;
Славянска 09:00 - Кремък 09:30 ;
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}