re = /(\d{2}:\d{2})/m
str = '*Линия - 1*
Славянска 07:00 - Кремък 07:30 ;
Славянска 08:00 - Кремък 08:30 ;
Славянска 09:00 - Кремък 09:30 ;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end