$re = '/(\d{2}:\d{2})/m';
$str = '*Линия - 1*
Славянска 07:00 - Кремък 07:30 ;
Славянска 08:00 - Кремък 08:30 ;
Славянска 09:00 - Кремък 09:30 ;
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);