// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{2}:\d{2})").unwrap();
let string = "*Линия - 1*
Славянска 07:00 - Кремък 07:30 ;
Славянска 08:00 - Кремък 08:30 ;
Славянска 09:00 - Кремък 09:30 ;
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}