const regex = /(\d{2}:\d{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2}:\\d{2})', 'gm')
const str = `*Линия - 1*
Славянска 07:00 - Кремък 07:30 ;
Славянска 08:00 - Кремък 08:30 ;
Славянска 09:00 - Кремък 09:30 ;
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}