const regex = /^.*?(\S+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?(\\S+)$', 'gm')
const str = `Austria: ac.at
Bangladesh: ac.bd
Belgium: ac.be
China: ac.cn
Cyprus: ac.cy
India: ac.in`;
const subst = `$Resolved URL$ LIKE "*$1/*"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);