use strict;
my $str = 'Austria: ac.at
Bangladesh: ac.bd
Belgium: ac.be
China: ac.cn
Cyprus: ac.cy
India: ac.in';
my $regex = qr/^.*?(\S+)$/mp;
my $subst = '$Resolved URL$ LIKE "*$1/*"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";