re = /^.*?(\S+)$/m
str = 'Austria: ac.at
Bangladesh: ac.bd
Belgium: ac.be
China: ac.cn
Cyprus: ac.cy
India: ac.in'
subst = '$Resolved URL$ LIKE "*$1/*"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result