# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"((?:\\"|[^"])*)"|'((?:\\'|[^'])*)'|(\\/\\/.*|\\/\*[\s\S]*?\*\\/)/[$1], [$2], [$3]/g;t' <<< "QUOTES
str = '//\''; // comment.'test'
str = \"//'\"; // comment.
str = '\'//\''; // comment.
str = '\"\'//\'\"'; // comment.
str = \"'// \"; // comment.
COMMENTS
/*'//\'';// hjkjh.'test'
\"//'\";// hjkjh.
'\'//\'';// hjkjh.
\"'// \";// hjkjh.*/ yo; // test.
// var i = 'able';"