const regex = /"((?:\\"|[^"])*)"|'((?:\\'|[^'])*)'|(\/\/.*|\/\*[\s\S]*?\*\/)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"((?:\\\\"|[^"])*)"|\'((?:\\\\\'|[^\'])*)\'|(\\\/\\\/.*|\\\/\\*[\\s\\S]*?\\*\\\/)', 'g')
const str = `QUOTES
str = '//\\''; // comment.'test'
str = "//'"; // comment.
str = '\\'//\\''; // comment.
str = '"\\'//\\'"'; // comment.
str = "'// "; // comment.
COMMENTS
/*'//\\'';// hjkjh.'test'
"//'";// hjkjh.
'\\'//\\'';// hjkjh.
"'// ";// hjkjh.*/ yo; // test.
// var i = 'able';`;
const subst = `[$1], [$2], [$3]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);