# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(- |\|)(?:(?!\1).)+$//gm;t' <<< "Trump tweets in China - how, and why does it matter? - BBC News
Trump tweets in China|how, and why does it matter?|BBC News"