re = /(- |\|)(?:(?!\1).)+$/m
str = 'Trump tweets in China - how, and why does it matter? - BBC News
Trump tweets in China|how, and why does it matter?|BBC News'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result