$re = '/(- |\|)(?:(?!\1).)+$/m';
$str = 'Trump tweets in China - how, and why does it matter? - BBC News
Trump tweets in China|how, and why does it matter?|BBC News';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;