import re
regex = re.compile(r"(- |\|)(?:(?!\1).)+$", flags=re.MULTILINE)
test_str = ("Trump tweets in China - how, and why does it matter? - BBC News\n"
"Trump tweets in China|how, and why does it matter?|BBC News")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)