const regex = /(- |\|)(?:(?!\1).)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(- |\\|)(?:(?!\\1).)+$', 'gm')
const str = `Trump tweets in China - how, and why does it matter? - BBC News
Trump tweets in China|how, and why does it matter?|BBC News`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);