#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(- |\|)(?:(?!\1).)+$"
Local $sString = "Trump tweets in China - how, and why does it matter? - BBC News" & @CRLF & _
"Trump tweets in China|how, and why does it matter?|BBC News"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)