use strict;
my $str = 'Trump tweets in China - how, and why does it matter? - BBC News
Trump tweets in China|how, and why does it matter?|BBC News';
my $regex = qr/(- |\|)(?:(?!\1).)+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";