#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^t\d{4,6}(?!\d|\b).+$"
Local $sString = "match:" & @CRLF & _
"t976490_old" & @CRLF & _
"t976490_24.05.3030" & @CRLF & _
"t123456someting" & @CRLF & _
"" & @CRLF & _
"It should not match:" & @CRLF & _
"t976490" & @CRLF & _
"t12345678someting" & @CRLF & _
"t123456 something" & @CRLF & _
"t1234 random" & @CRLF & _
"t12345674564564"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")