use strict;
my $str = 'match:
t976490_old
t976490_24.05.3030
t123456someting
It should not match:
t976490
t12345678someting
t123456 something
t1234 random
t12345674564564';
my $regex = qr/^t\d{4,6}(?!\d|\b).+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}