import re
regex = re.compile(r"^t\d{4,6}(?!\d|\b).+$", flags=re.MULTILINE)
test_str = ("match:\n"
"t976490_old\n"
"t976490_24.05.3030\n"
"t123456someting\n\n"
"It should not match:\n"
"t976490\n"
"t12345678someting\n"
"t123456 something\n"
"t1234 random\n"
"t12345674564564")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")