using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^t\d{4,6}(?!\d|\b).+$";
string input = @"match:
t976490_old
t976490_24.05.3030
t123456someting
It should not match:
t976490
t12345678someting
t123456 something
t1234 random
t12345674564564";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}