const regex = /^t\d{4,6}(?!\d|\b).+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^t\\d{4,6}(?!\\d|\\b).+$', 'gm')
const str = `match:
t976490_old
t976490_24.05.3030
t123456someting
It should not match:
t976490
t12345678someting
t123456 something
t1234 random
t12345674564564`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}