import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^t\\d{4,6}(?!\\d|\\b).+$";
final String string = "match:\n"
+ "t976490_old\n"
+ "t976490_24.05.3030\n"
+ "t123456someting\n\n"
+ "It should not match:\n"
+ "t976490\n"
+ "t12345678someting\n"
+ "t123456 something\n"
+ "t1234 random\n"
+ "t12345674564564";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}