$re = '/^t\d{4,6}(?!\d|\b).+$/m';
$str = 'match:
t976490_old
t976490_24.05.3030
t123456someting
It should not match:
t976490
t12345678someting
t123456 something
t1234 random
t12345674564564';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);