# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:.*\(.*)(\+|-{1})(?: )(\d+\.*?\d+)(?:.*\))//gi;t' <<< "option 1 ( + 10.2$ )
option 2 ( - 110.00$ )
option 2 ( - 110$ )
option 2 ( + 0.1$ )
"