re = /(?:.*\(.*)(\+|-{1})(?: )(\d+\.*?\d+)(?:.*\))/i
str = 'option 1 ( + 10.2$ )
option 2 ( - 110.00$ )
option 2 ( - 110$ )
option 2 ( + 0.1$ )
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result