// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:.*\(.*)(\+|-{1})(?: )(\d+\.*?\d+)(?:.*\))").unwrap();
let string = "option 1 ( + 10.2$ )
option 2 ( - 110.00$ )
option 2 ( - 110$ )
option 2 ( + 0.1$ )
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}