package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:.*\(.*)(\+|-{1})(?: )(\d+\.*?\d+)(?:.*\))`)
var str = `option 1 ( + 10.2$ )
option 2 ( - 110.00$ )
option 2 ( - 110$ )
option 2 ( + 0.1$ )
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}