# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:https?:\/\/)?(?:www\.)?\S+\.\S+$//gm;t' <<< "www.website1.com
www.website2.com
www.website3.nl
www.website3.nl !
www.website3.nl !
www.website3.nl !
www.website1.com
websit.ea.pl
websit.ea.pl
websit.ea.pl
http://www.website2.com
https://www.website2.com
"