package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:https?://)?(?:www\.)?\S+\.\S+$`)
var str = `www.website1.com
www.website2.com
www.website3.nl
www.website3.nl !
www.website3.nl !
www.website3.nl !
www.website1.com
websit.ea.pl
websit.ea.pl
websit.ea.pl
http://www.website2.com
https://www.website2.com
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}