use strict;
my $str = 'www.website1.com
www.website2.com
www.website3.nl
www.website3.nl !
www.website3.nl !
www.website3.nl !
www.website1.com
websit.ea.pl
websit.ea.pl
websit.ea.pl
http://www.website2.com
https://www.website2.com
';
my $regex = qr/(?:https?://)?(?:www\.)?\S+\.\S+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";