const regex = new RegExp('(?:https?://)?(?:www\\.)?\\S+\\.\\S+$', 'gm')
const str = `www.website1.com
www.website2.com
www.website3.nl
www.website3.nl !
www.website3.nl !
www.website3.nl !
www.website1.com
websit.ea.pl
websit.ea.pl
websit.ea.pl
http://www.website2.com
https://www.website2.com
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);