import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?://)?(?:www\\.)?\\S+\\.\\S+$";
final String string = "www.website1.com\n"
+ "www.website2.com\n"
+ "www.website3.nl\n"
+ "www.website3.nl !\n"
+ "www.website3.nl !\n"
+ "www.website3.nl !\n"
+ "www.website1.com\n"
+ "websit.ea.pl\n"
+ "websit.ea.pl\n"
+ "websit.ea.pl\n"
+ "http://www.website2.com\n"
+ "https://www.website2.com\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}