#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:https?://)?(?:www\.)?\S+\.\S+$"
Local $sString = "www.website1.com" & @CRLF & _
"www.website2.com" & @CRLF & _
"www.website3.nl" & @CRLF & _
"www.website3.nl !" & @CRLF & _
"www.website3.nl !" & @CRLF & _
"www.website3.nl !" & @CRLF & _
"www.website1.com" & @CRLF & _
"websit.ea.pl" & @CRLF & _
"websit.ea.pl" & @CRLF & _
"websit.ea.pl" & @CRLF & _
"http://www.website2.com" & @CRLF & _
"https://www.website2.com" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)