using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|[^\\])(?:\\\\)*(""(([^\n\\""]|\\.)*+)""|'(([^\n'])*+)')";
string input = @"abc""nail the 2x4 plank""def
abc""nail the 2\""x4\"" plank""def
abc""na\il the 2\""x4\"" plank""def
abc""na\\il the 2\\\""x4\\"" plank""def
abc""na\\\il the 2\\\\\""x4\\\"" plank""def
abc""na\\\\\il the 2\\""x4\\\"" plank\""def
abc""na\\\i\\""l\\\"" t\he 2\""x4\"" plank""def
abc""test""and""test""def
abc'test'and""test""def
abc""t'es't""and'test'def
abc'te""st'def
abc'te\'st'def
abc""\""te\""\""st\""def
""text""
""text \"" text""
""text text \\"" text""
'dhdhdh'
'jsfhjhhds\'
'kjzhfkja'\'
abc""some text""text here""pos\si\\b\\\le t\""ext""text""possible text""more text""""end text
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}