use strict;
my $str = 'abc"nail the 2x4 plank"def
abc"nail the 2\\"x4\\" plank"def
abc"na\\il the 2\\"x4\\" plank"def
abc"na\\\\il the 2\\\\\\"x4\\\\" plank"def
abc"na\\\\\\il the 2\\\\\\\\\\"x4\\\\\\" plank"def
abc"na\\\\\\\\\\il the 2\\\\"x4\\\\\\" plank\\"def
abc"na\\\\\\i\\\\"l\\\\\\" t\\he 2\\"x4\\" plank"def
abc"test"and"test"def
abc\'test\'and"test"def
abc"t\'es\'t"and\'test\'def
abc\'te"st\'def
abc\'te\\\'st\'def
abc"\\"te\\"\\"st\\""def
"text"
"text \\" text"
"text text \\\\" text"
\'dhdhdh\'
\'jsfhjhhds\\\'
\'kjzhfkja\'\\\'
abc"some text"text here"pos\\si\\\\b\\\\\\le t\\"ext"text"possible text"more text"""end text
';
my $regex = qr/(?<=^|[^\\])(?:\\\\)*("(([^\n\\"]|\\.)*+)"|'(([^\n'])*+)')/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}