import Foundation
let pattern = #"(?<=^|[^\\])(?:\\\\)*("(([^\n\\"]|\\.)*+)"|'(([^\n'])*+)')"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
abc"nail the 2x4 plank"def
abc"nail the 2\"x4\" plank"def
abc"na\il the 2\"x4\" plank"def
abc"na\\il the 2\\\"x4\\" plank"def
abc"na\\\il the 2\\\\\"x4\\\" plank"def
abc"na\\\\\il the 2\\"x4\\\" plank\"def
abc"na\\\i\\"l\\\" t\he 2\"x4\" plank"def
abc"test"and"test"def
abc'test'and"test"def
abc"t'es't"and'test'def
abc'te"st'def
abc'te\'st'def
abc"\"te\"\"st\""def
"text"
"text \" text"
"text text \\" text"
'dhdhdh'
'jsfhjhhds\'
'kjzhfkja'\'
abc"some text"text here"pos\si\\b\\\le t\"ext"text"possible text"more text"""end text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)