import re
regex = re.compile(r"(?<=^|[^\\])(?:\\\\)*(\"(([^\n\\\"]|\\.)*+)\"|'(([^\n'])*+)')", flags=re.MULTILINE)
test_str = ("abc\"nail the 2x4 plank\"def\n"
"abc\"nail the 2\\\"x4\\\" plank\"def\n"
"abc\"na\\il the 2\\\"x4\\\" plank\"def\n"
"abc\"na\\\\il the 2\\\\\\\"x4\\\\\" plank\"def\n"
"abc\"na\\\\\\il the 2\\\\\\\\\\\"x4\\\\\\\" plank\"def\n"
"abc\"na\\\\\\\\\\il the 2\\\\\"x4\\\\\\\" plank\\\"def\n"
"abc\"na\\\\\\i\\\\\"l\\\\\\\" t\\he 2\\\"x4\\\" plank\"def\n"
"abc\"test\"and\"test\"def\n"
"abc'test'and\"test\"def\n"
"abc\"t'es't\"and'test'def\n"
"abc'te\"st'def\n"
"abc'te\\'st'def\n"
"abc\"\\\"te\\\"\\\"st\\\"\"def\n"
"\"text\"\n"
"\"text \\\" text\"\n"
"\"text text \\\\\" text\"\n"
"'dhdhdh'\n"
"'jsfhjhhds\\'\n"
"'kjzhfkja'\\'\n"
"abc\"some text\"text here\"pos\\si\\\\b\\\\\\le t\\\"ext\"text\"possible text\"more text\"\"\"end text\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")