const regex = /(?<=^|[^\\])(?:\\\\)*("(([^\n\\"]|\\.)*+)"|'(([^\n'])*+)')/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|[^\\\\])(?:\\\\\\\\)*("(([^\\n\\\\"]|\\\\.)*+)"|\'(([^\\n\'])*+)\')', 'gm')
const str = `abc"nail the 2x4 plank"def
abc"nail the 2\\"x4\\" plank"def
abc"na\\il the 2\\"x4\\" plank"def
abc"na\\\\il the 2\\\\\\"x4\\\\" plank"def
abc"na\\\\\\il the 2\\\\\\\\\\"x4\\\\\\" plank"def
abc"na\\\\\\\\\\il the 2\\\\"x4\\\\\\" plank\\"def
abc"na\\\\\\i\\\\"l\\\\\\" t\\he 2\\"x4\\" plank"def
abc"test"and"test"def
abc'test'and"test"def
abc"t'es't"and'test'def
abc'te"st'def
abc'te\\'st'def
abc"\\"te\\"\\"st\\""def
"text"
"text \\" text"
"text text \\\\" text"
'dhdhdh'
'jsfhjhhds\\'
'kjzhfkja'\\'
abc"some text"text here"pos\\si\\\\b\\\\\\le t\\"ext"text"possible text"more text"""end text
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}