import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|[^\\\\])(?:\\\\\\\\)*(\"(([^\\n\\\\\"]|\\\\.)*+)\"|'(([^\\n'])*+)')";
final String string = "abc\"nail the 2x4 plank\"def\n"
+ "abc\"nail the 2\\\"x4\\\" plank\"def\n"
+ "abc\"na\\il the 2\\\"x4\\\" plank\"def\n"
+ "abc\"na\\\\il the 2\\\\\\\"x4\\\\\" plank\"def\n"
+ "abc\"na\\\\\\il the 2\\\\\\\\\\\"x4\\\\\\\" plank\"def\n"
+ "abc\"na\\\\\\\\\\il the 2\\\\\"x4\\\\\\\" plank\\\"def\n"
+ "abc\"na\\\\\\i\\\\\"l\\\\\\\" t\\he 2\\\"x4\\\" plank\"def\n"
+ "abc\"test\"and\"test\"def\n"
+ "abc'test'and\"test\"def\n"
+ "abc\"t'es't\"and'test'def\n"
+ "abc'te\"st'def\n"
+ "abc'te\\'st'def\n"
+ "abc\"\\\"te\\\"\\\"st\\\"\"def\n"
+ "\"text\"\n"
+ "\"text \\\" text\"\n"
+ "\"text text \\\\\" text\"\n"
+ "'dhdhdh'\n"
+ "'jsfhjhhds\\'\n"
+ "'kjzhfkja'\\'\n"
+ "abc\"some text\"text here\"pos\\si\\\\b\\\\\\le t\\\"ext\"text\"possible text\"more text\"\"\"end text\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}