$re = '/(?<=^|[^\\\\])(?:\\\\\\\\)*("(([^\n\\\\"]|\\\\.)*+)"|\'(([^\n\'])*+)\')/m';
$str = 'abc"nail the 2x4 plank"def
abc"nail the 2\\"x4\\" plank"def
abc"na\\il the 2\\"x4\\" plank"def
abc"na\\\\il the 2\\\\\\"x4\\\\" plank"def
abc"na\\\\\\il the 2\\\\\\\\\\"x4\\\\\\" plank"def
abc"na\\\\\\\\\\il the 2\\\\"x4\\\\\\" plank\\"def
abc"na\\\\\\i\\\\"l\\\\\\" t\\he 2\\"x4\\" plank"def
abc"test"and"test"def
abc\'test\'and"test"def
abc"t\'es\'t"and\'test\'def
abc\'te"st\'def
abc\'te\\\'st\'def
abc"\\"te\\"\\"st\\""def
"text"
"text \\" text"
"text text \\\\" text"
\'dhdhdh\'
\'jsfhjhhds\\\'
\'kjzhfkja\'\\\'
abc"some text"text here"pos\\si\\\\b\\\\\\le t\\"ext"text"possible text"more text"""end text
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);