#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\G(?!^)|<)[^<>\s]*\K\s++(?=[^<>]*>)"
Local $sString = "<ta gname>foreign text with space that needs to stay like this< /endtag>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)