import re
regex = re.compile(r"(?:\G(?!^)|<)[^<>\s]*\K\s++(?=[^<>]*>)", flags=re.MULTILINE)
test_str = "<ta gname>foreign text with space that needs to stay like this< /endtag>"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)