re = /(?:\G(?!^)|<)[^<>\s]*\K\s++(?=[^<>]*>)/m
str = '<ta gname>foreign text with space that needs to stay like this< /endtag>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result