import Foundation
let pattern = #"(?:\G(?!^)|<)[^<>\s]*\K\s++(?=[^<>]*>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<ta gname>foreign text with space that needs to stay like this< /endtag>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)