using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|<)[^<>\s]*\K\s++(?=[^<>]*>)";
string substitution = @"";
string input = @"<ta gname>foreign text with space that needs to stay like this< /endtag>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}