$re = '/(?:\G(?!^)|<)[^<>\s]*\K\s++(?=[^<>]*>)/m';
$str = '<ta gname>foreign text with space that needs to stay like this< /endtag>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;