const regex = /(?:\G(?!^)|<)[^<>\s]*\K\s++(?=[^<>]*>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)|<)[^<>\\s]*\\K\\s++(?=[^<>]*>)', 'gm')
const str = `<ta gname>foreign text with space that needs to stay like this< /endtag>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);